Ubuntu 14.04でL2TP/IPsecでエラー

久々に必要があって
Ubuntu 14.04でL2TP/IPsecサーバをセットアップしたのですが、
クライアントから接続しようとしても失敗してしまいます。
しょうがないのでサーバで

# tail -f /var/log/syslog

を実行して接続時のログを見ていると、

xl2tpd[****]: <省略>
pppd[****]: The remote system is required to authenticate itself
pppd[****]: but I couldn't find any suitable secret (password) for it to use to do so.
xl2tpd[****]: <省略>

とか出てきます。

パスワードはさっき”/etc/xl2tpd/l2tp-secrets”ファイルに書いたんだけど…
とか思いつつよくみると、エラーを吐いているのはpppdです。んっ?

試しに設定ファイル”/etc/ppp/chap-secrets”に

<ユーザ名> * <パスワード> *

の形式で書いてみるとちゃんと動きました。
昔と挙動が違いますが、動いたからまあいいや。