ServersMan@VPS(Debian32bit)の”apt-get update”でエラーが出る

ものすごく久しぶりに

# apt-get update

したのですが、
http://ftp.debian.org でdebian-volatileディレクトリと
debian-securityディレクトリに関連してエラーが出ています。
squeezeになってなくなったのね。
lennyからsqueezeへのアップデートの正式な方法
きちんと読むべきなんでしょうが、
とりあえず/etc/apt/sources.listの内容を

deb http://ftp.debian.org/debian squeeze main contrib non-free
deb http://security.debian.org/ stable/updates main contrib non-free

に変更(なくなったディレクトリに対する行を削除してlennyをsqueezeに置換)して

# apt-get update
# apt-get upgrade
# apt-get dist-upgrade

でなんとなく動いてるっぽいんでまあこれでいいのかなと。

気がつけばsqueezeの正式リリースから約1年経っており、
本当はもっと前にやっておくべきだったのでしょうが、
動いているものは変えないほうがいいというのもまた真だったりするので。